Hacked By Yuriz MA
Accueil du site > X. Téléchargements. > 4. Le Puzzle du Batteur - The Drummer’s ’G’igsaw : UPDATE compatible Lilypond (...) > Le Puzzle du Batteur - The Drummer’s ’G’igsaw : UPDATE (le 23/07/2011) (...)

Le Puzzle du Batteur - The Drummer’s ’G’igsaw : UPDATE (le 23/07/2011) compatible avec Lilypond 2.14.


UPDATE (le 23/07/2011) Puzzle du Batteur - The Drummer’s ’G’igsaw :

Compatibilité avec Lilypond 2.14

Correction d’un bug mineur.

La Bibliothèque n’est pas updatée mais tous les patterns sont utilisables comme avant.

+ Interface graphique pour traitement aléatoire du timing et/ou du volume midi, écrite en Python.

Disponible pour Linux seulement.

Après votre téléchargement la première chose à faire sera de lire le pdf

LISEZ-MOI. Vous devez SUPPRIMER ou RENOMMER l’ancienne

installation avant de décompresser une nouvelle version.

First of all read the README.pdf after your download. You must

DELETE or RENAME the old installed version before you’d

decompress the new one.

DÉPENDANCES

Vous devez installer :

* GNU Lilypond >= 2.14.1 http://lilypond.org

* midicomp 0.0.4 http://midicomp.opensrc.org/midicomp-0.0.4.tar.gz

Télécharger midicomp 0.0.4 puis, en console root, le déplacer vers

/usr/local (ou même /usr) :

# mv /TON/CHEMIN/.../midicomp-0.0.4.tar.gz /usr/local (ou même /usr)

Aller, toujours en root, dans /usr/local (ou même /usr)

# cd /usr/local (ou /usr) Décompresser le paquet :

# tar -zxvf midicomp-0.0.4.tar.gz

puis aller dans le nouveau dossier qui a été créé :

# cd /usr/local/midicomp-0.0.4 (ou /usr) et taper (toujours en root) :

# make

En choisissant /usr le fichier binaire devrait être installé dans /usr/bin automatiquement mais je crois que dans le cas de /usr/local il faut déplacer ce fichier dans /usr/local/bin après la compile :

# mv /usr/local/midicomp-0.0.4/midicomp /usr/local/bin

* Python 2.6.x avec l’option Tk activée à la compilation. Par défaut dans votre distribution de Linux.

* GNU Bash, GNU awk and GNU sed Par défaut dans votre distribution de Linux.

J’utilise Timidity++ 2.13.2 avec eawpatches comme config midi par défaut.

******

INSTALLATION

Décompressez l’archive. (tar jxvf ....)

Dans un terminal allez dans votre répertoire Drummer-s-Gigsaw :

cd /home/....../Drummer-s-Gigsaw

et lancer le script bash :

sh INSTALL.sh

L’installation est terminée.

******

* Avec cette nouvelle version vous n’avez plus du tout besoin de gvim.

Vous pouvez donc utiliser votre éditeur de texte préféré ou même un éditeur dédié comme Frescobaldi ou Lilypondtool...

* Vous pouvez désormais écrire toutes les valeurs de note, de la ronde (1) à la quintuple croche (128) et même les valeurs pointées.

* Le manuel est mis à jour.

Ayez du bonheur.

BZip - 8.6 Mo
Drummer-s-Gigsaw-tar.bz2
UPDATE (23/07/2011) compatible Lilypond 2.14

Suivre la vie du site RSS 2.0 | Plan du site | Espace privé | SPIP | squelette

Creative Commons License
Sur ce site, les écrits,les partitions et les fichiers sonores dérivés sont sous license:
(On this site, writings,sheet music and derivated audiofiles are licensed under a:)
Creative Commons Attribution-Noncommercial-Share Alike 3.0 License
Seul le Puzzle du Batteur est sous licence GPLv3 or later.
Only the Drummer's "Gigsaw" is under GPLv3 or later License. (http://www.gnu.org/licenses/)